How to set proper docking input data (AWS Batch)?

Hi, very new to VFVS. I am following the Github tutorial for VFVS 2 and I have a .pdbqt file. My config.txt looks like this:

receptor = ../input-files/receptors/qvina02_rigid_receptor1/Rabbit-eEF1a-ADP-5LZS-Apo-Prepped.pdbqt
center_x = 265
center_y = 335
center_z = 200
size_x = 17
size_y = 20
size_z = 15
exhaustiveness = 1
cpu = 1

In my all.ctrl, I set my docking variables to:

docking_scenario_names=qvina02_rigid_receptor1
docking_scenario_programs=qvina02
docking_scenario_basefolder=../input-files/receptors

I set it to run with AWS Batch, and the status says successful.

-----------------------------------------------------------------
AWS Batch Progress
-----------------------------------------------------------------

Docking count is inaccurate for sensor screens. Correct value will
be in 'Completed Summary' when finished.

         Status   Workunits        Subjobs      Dockings (est.)
      SUBMITTED       0               0                 0
        PENDING       0               0                 0
       RUNNABLE       0               0                 0
       STARTING       0               0                 0
        RUNNING       0               0                 0
      SUCCEEDED       1              200             387140
         FAILED       0               0                 0

Active vCPUs: 0

However, if I were to read the stdout of one of the jobs, it says it cannot find my receptor file.

STDERR:


Error: could not open "../input-files/receptors/qvina02_rigid_receptor1/Rabbit-eEF1a-ADP-5LZS-Apo-Prepped.pdbqt" for reading.

I want to put this in an s3 bucket but cannot find documentation on how to provide that information on VFVS 2.0. How can I share my receptor file so that all my jobs can access it?

Dear Ethan,

Thank you for your interest in VirtuaFlow.

This is incorrect. In the tutorial, no subfolder in the receptor folder is used. But in your setting above you introduced a subfolder, which does not work.

All the best,
Christoph

Hi Christoph,

Thank you so much for your help.

Based on your suggestion, I changed the receptor path in the config.txt and set docking_scenario_names to be empty, instead of the previous value qvina02_rigid_receptor1,

we continue to encounter the same error.

Error: could not open "../input-files/receptors/receptor1.pdbqt" for reading.

Do you have any further suggestions to help us resolve this error? We would really appreciate any additional guidance.

Thanks,
Ethan

Hi Christoph,

Bringing this to your attention again. We have yet to fix this issue. Since we have the receptor file, do you know how we can specify an s3 location for it? Is it based on the docking options? Thanks.