error and fix

Hey admins,

I’ve noticed an error regarding the file when trying to continueing failed queues:

> # Copying the new job file
> cp ../${job_template} ../../workflow/job-files/main/${new_job_file}
> . subjobfiles

what worked for me was:

# Copying the new job file
cp ../templates/${job_template} ../../workflow/job-files/main/${new_job_file}
. subjobfiles

or just putting the template file in the /tools folder also worked. Since the template files are not in the tools folder the original code doesnt worked and gets trapped.

Note: I also suggest checking your .bashrc file before you start your screening, since user specific aliases and functions of other softwate has multiple times caused my joblines to not even start and causing the jobline submission to fail.

Furthermore, I also tried running other jobs so I had to turn some aliases and function back on and as soon as a new jobline queue had to be submitted it instantly failed submission.

1 Like

Hi Kaneki,

Good catch, thanks for letting us know.

Do you want to make a pull request with the bugfix in the Github repo? Otherwise we can also fix it directly.


Hi Christoph,

I’ve created a pull request on Github. Let me know if there is anything to change there :slight_smile:

1 Like

Hi Arthur,

Thank you, we appreciate your efforts :slight_smile:

Merge has been done.